Installation for Other Operating Systems

Packages are not yet provided for other Linux/BSD based operating systems so manual installation is necessary (check the open issue).


  • Install the following dependencies which are required for the oversip Ruby Gem to properly compile:
    • Ruby >= 1.9.3
    • Ruby development library (version >= 1.9.3)
    • Ruby Gem (which provides the gem command)
    • make
    • C compiler (i.e. gcc).
    • C++ compiler (i.e. g++).
    • OpenSSL development library
    • libev development library (version >= 4.0)

Gem installation

  • Install the oversip Gem (the gem command may be called gem1.9 or gem1.9.X depending on each operating system):
    gem install oversip

Default configuration files

The Gem provides a default etc/ directory that should be copied as /etc/oversip/ in the host filesystem. The exact location of the installed Gems depends on each operating system.

  • The following command does the work:
    cp -a $(dirname $(gem which oversip))/../etc /etc/oversip

Create an oversip system user

OverSIP must be started by the root user (i.e. it needs privileges for binding in ports minor than 1024). Once it is started it can change the running user and group.

  • Create an oversip system user (use the proper command in your operating system):
    adduser --quiet --system --group --disabled-password \
            --shell /bin/false --gecos "OverSIP" \
            --home /var/run/oversip oversip

Init/default script

An init script would also be required for a proper installation. Unfortunately this is an open task, if you want to collaborate check the following item:

  • Open issue (“Create packages for Centos, RedHat, *BSD…”).